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Introduction




AI Editor 
is a Windows application for creating and editing Age of Empires (AoE) and AoE Expansion, or Rise of Rome (RoR) AI (artificial intelligence) files.



AI files are basically text files with extension .ai. By modifying them you can create new computer player strategies. They can be included in scenarios, and this generally makes scenarios a greater challenge and more fun to play. The game does not include any utility for editing such files - the text editor is supposed to be the one. But if you have tried it with the text editor, you know it is not the

easiest job. So I decided to write a little utility to fill the gap. 



The contents of the AI files is described more thoroughly below in this document. Basically they contain the units, buildings and research that will be performed by the computer player in the general order listed. The computer will try to progress through the list and maintain what has been built. When a unit or building in the list is destroyed, it will generally be replaced before a new unit or building further down on the list will be created.



What makes editing of AI files difficult with the usual text editing tools? There are too many rules you must obey and magic numbers you must remember in order to do it right. As mentioned above, an AI file is a list of all objects that will be built by the computer player during a game. And the sequence of items in this list is important. For example, a Market must be built before a Farm, a Barracks before a Clubman, etc. In other words, the game rules must be respected by maintaining the prerequisite order. As long as this is true, items in the list can be re-sequenced. Here it is expected that you will refer to the technology tree foldout as a good reference source for the prerequisites. But consider - there are 121 objects in the game (RoR) and each one has a required age, a parent and 0 to 2 prerequisites. Additionally, not all objects are allowed for all 16 civilizations (unless you play in full tech tree mode). Furthermore, there are 2 versions of the game, and there are 9 objects that are unique to RoR and cannot be placed in AI files created for the original AoE. 



There is still another inconvenience that should be mentioned here. The AI files contain mostly numbers. These numbers are object codes. Although object names can be placed in items, they are not used by the game. For example, the Town Center code is 109. If you write "B109 Barracks" the game will read the code "B109" and ignore the name "Barracks", and therefore a Town Center will be built. In the usual way of editing, you are forced to know 121 object codes by heart, or constantly refer to some documentation, or copy/paste items around like hell. No matter how you do it, there is a great possibility of mistakes.



Of course, you could learn all these rules, refer to the appropriate sources, copy/paste items from sample AI files and do it right this way. What you could not do at all with the text editor is verify your work. The only "verification tool" you have is the game itself. Imagine - you write a list of about 100 items, run the game and patiently wait to see what happens just to find out that "this Centurion at position 96 should be after the Aristocracy at position 99", or "this Cataphract is actually a Centurion, I must have placed a wrong code". In the ideal case, you should have a way to discover all such bugs before running the game, and launch the game only to evaluate the competitiveness of your newly created strategy, not the correctness of the list.



The AI Editor saves you most of these pains. It is a nice utility with a graphical user interface that opens and saves AI files in the format that is used by the game. An AI file saved with AI Editor is guaranteed to load OK. You need not worry about object codes at all - you work with the textual descriptions, and the program places the right codes for you. The technology tree and the prerequisites and conditions for all 121 objects are built into the editor. At any time, you can see the overall status of your AI, which says whether there are wrong or misplaced items in the list. And if so, you can see a list of all invalid items. You can still save an incorrect list, but not without being aware of this. The new version of AI Editor lets you also specify for which game (AoE or RoR) and which civilization you are creating your AI file, and performs additional checking based on these conditions. The new version also includes a clipboard support, which lets you cut, copy and paste items just like you would do it with the text editor, which can speed your work a lot. You can also edit the introductory and trailing comments, which you can use to explain to users of your AI what exactly you are trying to achieve with your strategy.



Here follow some history notes for the curious. The first version of AI Editor was released in November 1997, shortly after the game was in stores. At the same time I wrote 2 other AoE tools, CPNBUILD and DRSBUILD, for editing campaign files and the resource files of the game. These 3 tools were one of the first third party tools ever released for AoE. They enjoyed great popularity for some time. All three were posted to most AoE fan sites and included in several CD-ROM collections. Since then, I have received emails with thanks, questions, and complaints from many people. I have released several small updates to the 2 other tools, but I have never updated the AI Editor. The reason was that I had other matters to attend meanwhile. I was a soldier for some time (the military service is obligatory in my country Bulgaria), then I married and returned to my job, and was devoting most of my time to my wife and my career as a software developer. At last I found some free time and enthusiasm to return to my long delayed work on the AoE tools. And here it is, AI Editor version 2.0, which I think comes not too late to be useful to many people, especially novice or expert AoE scenario designers.



This document contains practically everything I have to say about AI Editor. It contains notes on installation, using AI Editor, a short guide on how to edit AI files, and other important notes concerning this program.



In order to be legal, I am expected to say here a few additional things.



AI Editor is a FREE software. This means that you may use it as long as you wish without paying me anything. You may also copy and redistribute it without any limitations, provided that the distribution is kept unmodified in its original form. You may send it to your friends, post it to your AoE fan site or include it on your CD-ROM. But you may NOT hack it or sell it. I am not trying to make money out of it, so I will consider it extremely impolite if you try to do so.



This software comes with ABSOLUTELY NO WARRANTY of any kind, so USE IT AT YOUR OWN RISK. 



Microsoft (MS) and Age of Empires (AoE) are trademarks of Microsoft Corporation. All other trademarks are property of their respective owners.



What's New



This version of AI Editor implements the following new features:



The long awaited support for RoR AI files. RoR contains 9 new objects, and therefore most AI files created for RoR did not load with the first version of AI Editor.



Support for games as prerequisites. In the Settings dialog, you can specify for which game, AoE or RoR, you are creating your strategy. If you specify AoE and try to include a RoR-specific object, for example Slinger, the status of your AI will evaluate to "BAD" and you will see after clicking on this item that this object is not supported by AoE.



Support for civilizations as prerequisites. In the Settings dialog, you can specify for which one of the 16 civilizations you are creating your strategy. If you try to include an object that is not allowed for the specified civilization, for example Cavalry with Egyptian, the status of your AI will evaluate to "BAD" and you will see after clicking on this item that this object is not allowed for the currently specified civilization. You can also choose to work in "All - full tech tree" mode, where these limitations are ignored.



Overall AI status and listing of invalid items. If it is "ok", then your list doesn't contain wrong or misplaced items. If it is "BAD", then your list contains such items, and you can see them in the Invalid Items dialog.



Status bar that displays the currently selected game and civilization, as well as the overall AI status.



Clipboard support. You can now select multiple items for the list and perform the usual clipboard operations Cut, Copy and Paste on them. This can speed your work a lot.



Editing of comments. There is a new dialog Comments in which you can edit the introductory and trailing comments that are placed in the file when it is saved.



Viewing statistics. You can open the new dialog Statistics to view how many buildings and units of each kind you have in your list, as well as the total number of buildings, units and research.



Installation



It is simple. The original package is a ZIP archive called aiedit20.zip, which contains the following files:



aiedit.exe �AI Editor executable��aiedit.doc�AI Editor documentation (MS Word document, the file you are currently reading)��objects.xls�Reference information about AoE objects (MS Excel sheet) ��
stratsmp.ai�A sample AoE AI file released by Ensemble Studios��
readme.txt
�
AI Editor README file
��


Unzip the archive in a folder of your own choice, for example C:\Program Files\aiedit. After unzipping, create a shortcut to the executable aiedit.exe in your Start menu or on your desktop. In order to do this, click somewhere on your desktop, point to New->Shortcut, and use the dialog that appears to specify the path where you have placed the executable and the name of your shortcut.



You may also wish to associate .ai files with this utility, so when you click on such a file, it is opened in AI Editor automatically. In the Windows Explorer, point to View->Folder Options->File Types and click on the New Type button. In the dialog that appears, specify a description, an extension ".ai", a content type "text/plain", and then click on the New button to create a new action. Name this action Open and specify the path to aiedit.exe. Now when you look at an AI file in the Explorer, it is shown with the AI Editor icon. When you click (or double-click, if you are using the non-web interface) on this file, it will be opened in the AI Editor automatically. Most AI files you have are most probably located in the folders data and data2 under your AoE or RoR installation folder.



Using AI Editor



Starting



To start AI Editor, simply click on its icon. You can also start it from the command line and specify a filename to edit, or click on some .ai file in the Explorer to open it.



General Editing



After you start AI Editor, the main window (Pic. 1) is displayed. It consists of 2 parts, the list box and the status bar. 
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Picture 1. AI Editor Main Window



The multiple selection list box contains the edited list of AI items. The information about each object in the list is presented in 5 columns. These are Code, Description, Quantity, Parent and Retrains. The meaning of these columns is explained below in the Editing AI Files section. You can edit an item from this list by double-clicking on it or pressing Enter, add item by pressing the Ins key and delete items by pressing the Del key. You can select multiple items by holding down Shift or Ctrl keys and clicking with the mouse in the usual way. When multiple items are selected, you can perform on them operations such as Cut, Copy, Paste and Delete.



The status bar displays the currently selected game and civilization, as well as the current AI status. If this status is "BAD", there must be wrong or misplaced items in the list. If it is "ok", there are no such items.



File Operations

Creating a New AI List



To create a new AI list, choose New from the File menu, or press Ctrl+N. A new AI list which contains a single Town Center is created and displayed. Before the first save, the file is named Untitled.ai. By default, such a list is created every time you start AI Editor without parameters.



Opening an Existing AI List



To open an existing AI list, choose Open... from the File menu, or press Ctrl+O. A file selection dialog box is displayed. Choose the file you want to edit there. If the file that you have chosen contains a valid AI list, it is opened and the list is displayed in the AI Editor window. The name of the opened file is displayed on the title bar. If errors are encountered during loading, an error message that says "Error reading file <filename>: bad file format." is displayed. This message may mean that you are trying to open a file that is no AI file at all, or that the AI file you are trying to open contains unknown object codes. The old version (1.0) of AI Editor usually issued this message when it tried to open RoR AI files, since they generally contain some object codes which were not supported in this version.



Saving the AI List



To save the current AI list, choose Save from the File menu, or press Ctrl+S. The file is saved under its original name (displayed in the title bar). 



Saving the AI List Under a New Name



To save the current AI list under a new name, choose Save As... from the File menu. A file selection dialog box is displayed. Specify the new name of the file there. Note that if a file with this name already exists, you will not be prompted for confirmation, so be careful not to overwrite your work. The file is saved under the specified name. The new name appears in the title bar. 



Major Editing Operations

Adding/Editing Items in the AI List



Adding and editing items in the AI list is similar in that both are done in the same dialog box. To add a new item to the AI list, select the item after which you want to add the new item and choose Add... from the Edit menu, or press Ins. To edit an existing item in the AI list, select the item you want to edit and choose Edit... from the Edit menu, or press Enter, or simply double-click the item. The Add/Edit AI Item dialog box (Pic. 2) is displayed. 
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Picture 2. AI Item Dialog Box



In this dialog box, you can specify various properties for the item your are adding or editing. 



In the Item type box, you can specify the type of the item - Building, Unit or Research. Additionally, for buildings and units you can specify that this item should be rebuilt, or "retrained" a limited number of times. By default, all items are retrained unlimitedly. For research, you can specify that this research item is critical for the subsequent progress. Generally you should mark as critical ages, which are a special kind of research. See the section Editing AI Files for more information on these issues.



Each building or unit object can be built (trained) in a certain quantity which is greater than or equal to 1. This quantity can be specified in the Quantity edit box. By default it is 1. Technologies cannot be researched more than once, and therefore this edit box is disabled for them.



If Limited retrains is checked for a building or unit, the number of retrains can be specified in the Retrains edit box. By default it is 0, which means that the computer will not try to retrain this objects at all if it is destroyed. For technologies and for buildings/units that have not Limited retrains checked, this edit box is disabled.



In the Item object box, you can specify the exact object you want to be placed in the list. Select this object in the Description combo box. This combo box lists only items of the type chosen in the Item type box. For example, if Unit is the chosen type, the Description dialog box will list only units, and not buildings or technologies. Since some units and their corresponding upgrade technologies have equal names, descriptions of all technologies begin with "R." to be easily distinguished. 



You may be surprised at first that you cannot find some units in the list. For example, you will not find a unit named "Catapult". The reason for this is that the Catapult is actually an upgrade of the Stone Thrower. So all 3 units in this upgrade sequence - Stone Thrower, Catapult and Heavy Catapult, are represented by the same object code U35. Such cases are generally represented by descriptions like "Stone Thrower/...". The slash and ellipsis suggest that this is actually an upgrade sequence, and not a single unit. If you want the computer to produce Catapults, you will have to place "Stone Thrower/..." in the list and make sure that the appropriate upgrade "R. Catapult" is already researched at this point.



After you select your object, look at the information panel below the combo box. It displays information about prerequisites and conditions for the object you have chosen, and more important it says whether they are fulfilled or not. The fields in this panel are listed in the table below.



Table 1. Information fields in the Object description box

Field�Description��Code�Object code. This code is what is actually read by the game when it loads the file. The code consists of a single letter prefix and a numeric identifier in the range 0 - 360. You never need to mess with these codes when you use AI Editor. The code is built-up automatically and is displayed only for you reference. It can be helpful to experienced AI designers who are accustomed with these codes.��Age�Required age for this object. In order to build anything, you must have reached the corresponding age. In brackets is displayed the current age at the point you are inserting/editing and the status of the ages comparison. It is "ok" if the required age is reached at this point, and "BAD" if the age is not reached yet.��Parent�Parent of this object. In order to build most of the objects, you must have built its parent first. The parent is actually the building in which the training/research is performed. In brackets is displayed the availability of the parent at the point you are inserting/editing. It is "available" if the parent is available at this point, and "NOT AVAILABLE" if the parent is not built yet. An object may have no parent (for example all buildings), in which case the parent is stated simply as "None".��Prerequisite #1, Prerequisite #2�Prerequisites for this object. In order to build many of the objects, you must have built/researched 1 or 2 prerequisites first. These prerequisites are displayed here. In brackets is displayed the availability of the prerequisite at the point you are inserting/editing. It is "available" if the prerequisite is available at this point, and "NOT AVAILABLE" if the prerequisite is not built/researched yet. An object may have no prerequisites or only a single prerequisite, in which case the prerequisite is stated simply as "None". Buildings have buildings for prerequisites. Units and technologies have technologies for prerequisites.��Games�Games by which this object is supported. There are 9 objects which are supported by RoR, but not by the original AoE. For these, the text is "RoR". For all other objects, it is "All", which means that they are supported both by AoE and RoR. In brackets is displayed the correctness of the choice with respect to the currently selected game. It is "ok" if the object is supported by the current game, or if "Both" is selected for the current game, and "BAD" if this objects is one of the 9 RoR-specific objects and the current game is AoE.��Civs�Civilizations for which this object is allowed. There are a number of objects which are forbidden for each of the 16 civilizations. For these, the text is "All, except:" followed by a list of all civilizations that may not build this object. For all other objects, it is "All", which means that they are allowed for all civilizations. In brackets is displayed the correctness of the choice with respect to the currently selected civilization. It is "ok" if the object is allowed for the current civilization, or if "All - full tech tree" is selected, and "BAD" if this object is one of the objects that are not allowed for the currently selected civilization.��

As a general guideline, after choosing an object, you should take a brief look at this information panel. If you do not notice any uppercase phrases, then the object is OK. If you see "BAD" or "NOT AVAILABLE" anywhere, then you should examine the case and correct the mistake. Reference information about the prerequisites of all game objects can be found in the file objects.xls, included in the AI Editor distribution.



When you have finished editing the properties of the item, you can press OK to commit your changes to the list and close the dialog box. Your new item is added to the list at the appropriate position, or the changes to the existing item come into effect. If you choose Cancel instead, your changes are ignored and no item is inserted or changed.



Deleting Items from the AI List



To delete a single item or a number of items from the current AI list, select the item(s) and choose Delete from the Edit menu, or press Del. A confirmation prompt asking "Are you sure you want to delete the selected <number> items?" is displayed. If you confirm by pressing Yes, the selected item(s) will be removed from the list and there is no way to bring them back. Be careful with this command, and remember that there is no "Undo" command. If you issue it by accident, simply press No at the confirmation prompt, and no items will be deleted.



Clipboard Operations



Cutting Items from the AI List



To cut item(s) from the current AI list, i.e. remove them form the list and copy them to the clipboard, select the item(s) and choose Cut from the Edit menu, or press Ctrl+X or Shift+Del. A confirmation prompt asking "Are you sure you want to delete the selected <number> items?" is displayed. If you confirm by pressing Yes, the selected item(s) will be removed from the list and copied to the clipboard. This command overwrites the original clipboard contents. 



Copying Items from the AI List



To copy item(s) from the current AI list to the clipboard, select the item(s) and choose Copy from the Edit menu, or press Ctrl+C or Ctrl+Ins. The selected item(s) are copied to the clipboard. This command overwrites the original clipboard contents. 



Pasting Items to the AI List



To paste previously copied item(s) from the clipboard to the current AI list, select the item after which you want the items to be inserted and choose Paste from the Edit menu, or press Ctrl+V or Shift+Ins. The item(s) are inserted to the list at the appropriate point. If the clipboard doesn't contain copied items, an error message that says "Error reading file clipboard: bad file format." is displayed. In this case, the clipboard is treated as a special file hat is shared by all Windows applications.



Selecting All Items in the AI List



To select all items in the current AI list, choose Select All from the Edit menu, or press Ctrl+A. All items in the list are selected and a subsequent operation Cut, Copy or Delete can be issued on them. This command can speed up your work at times, but it should be used with care, since 2 of these 3 commands are destructive.



Setting Options



Specifying the Game and Civilization



To specify the game and civilization for which you are creating your strategy, choose Settings... from the Options menu, or press Ctrl+T. The Settings dialog box (Pic. 3) is displayed. 
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Picture 3. Settings Dialog Box



In this dialog box, you can select the game and the civilization for which you are creating your strategy. For the game, you can select "AoE", "RoR" or "Both" in the Game combo box. "Both" means that no game-based checking is made for the objects in the list. Since there are no objects which are valid for AoE and invalid for RoR, this choice is equivalent to "RoR". For the civilization, you can select any of the 16 civilizations, or "All - full tech tree" in the Civilization combo box. The latter choice means that no civilization-based checking is made for the objects in the list, and that civilization-specific limitations are ignored. Choose this for AI that will be played with the "Full Tech Tree" option of the game enabled.



When you are done with your settings, press OK to commit them and close the dialog box. If you choose Cancel, your changes will be discarded. The currently selected game and civilization are displayed in the status bar and in the AI Item dialog when it is opened.



Editing Comments



To specify the initial and trailing comments that are placed in your file when it is saved, choose Comments... from the Options menu, or press Ctrl+M. The Comments dialog box (Pic. 4) is displayed. 
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Picture 4. Comments Dialog Box



In this dialog box, you can edit the comments that are placed at the beginning (Banner edit box) and at the end (End edit box) of your file. All lines that you place here should be preceded with a double slash "//" in order to be regarded as comments. These comments are not obligatory and are ignored by the game on load. They are however important to any humans which may look at your AI file, so do not underestimate them. As a general convention, you should place a short description of the strategy you are creating, as well as information about you (the author) and a copyright notice at the beginning of your file. If you release several revisions of your AI, information about these revisions should also be placed in these comments. If you are familiar with revision control systems (RCS, CVS, etc.), you can place there a revision identifier "$Id: $" and a change log "$Log: $". Usually the identifier is placed at the beginning, and the log is placed at the end of the file. 



By default, AI Editor places the following comments in your file:



//AoE artificial intelligence (AI) file

//$Id: $



//$Log: $

//Made with AI Editor

//AI Editor written by Stoyan Ratchev, sratchev@mail.techno-link.com

//End



When you are done with editing of comments, press OK to commit the changes you have made to these comments and close the dialog box. If you choose Cancel,  your changes will be discarded. 



Viewing Information




Viewing Invalid Items



To see a list of all invalid items in the current list, choose Invalid Items... from the File menu, or press Ctrl+I. The Invalid Items dialog box (Pic. 5) is displayed. 
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Picture 5. Invalid Items Dialog Box



In this dialog box, you can see a list of all items that are wrong or misplaced. If the AI status displayed on the status bar is "ok", the list will be empty. Otherwise, it will contain all items that cause problems in the same format in which they are displayed in the main list. To see what is exactly wrong with an item, close this dialog box, find it in the main list, double-click it to open the Edit AI Item dialog box and look at the information panel in the Item object box. It will say "BAD" or "NOT AVAILABLE" in some of the fields. Decide what you must do to correct the error. Hunt down in this way all invalid items and correct them until the AI status says "ok".

Viewing Statistics



To see some statistics about the current list, choose Statistics... from the File menu, or press Ctrl+J. The Statistics dialog box (Pic. 6) is displayed. 
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Picture 6. Statistics Dialog Box



In this dialog box, you can see how many buildings and units of each kind you have in your list, and the total number of buildings, units and research.



Viewing Help



To see an information dialog box about AI Editor, choose About... from the "Help" menu. The About dialog box (Pic. 7) is displayed. 
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Picture 7. About Dialog Box



This dialog box contains information about the current version of AI Editor. 



Editing AI Files



There is a lot of information on the Net about creating and editing AI files. The first complete guide, and still the most comprehensive one, is the set of articles entitled "Breakdown of .ai" on AoE Heaven, http://age.gamestats.com/age/siege/articles/aifiles.shtml. Although it contains lots of useful information, this guide, like most guides on the Net, is still devoted to "how to do it right with the text editor". Therefore I decided to include in this document some sort of a guide which explains "how to do it better with AI Editor". I have rewritten many things form the AoE Heaven guide, and here I am giving its authors full credits for this. 



Overview



As it was already mentioned, AI files contain the units, buildings and research that will be performed by the computer player in the general order listed. The computer will try to progress through the list and maintain what has been built. When a unit or building in the list is destroyed, it will generally be replaced before a new unit or building further down on the list will be created.



Not all game objects need to be explicitly included in the list in order to be built by the computer player. Storage Pits, Houses, and Granaries, although they can be explicitly included in the list, can be handled completely by the computer player. In other words, these need not be placed in the list at all; the computer player will build them when they are needed. A sample list is located in the Docs directory of the Age of Empires CD-ROM. It is also included in the AI Editor distribution in the file stratsmp.ai.



The sequence of items in this list is important. For example, a Market must be built before a Farm, etc. As long as the game rules are respected by maintaining the prerequisite order, items in the list can be re-sequenced. With AI Editor, you can do this without referring to any technology tree foldouts and other reference sources. All you should care is maintain the status of your AI list to be "ok".



Items on the list that cannot be built or researched (for any reason) are eventually skipped. If there are already units on the board that are also in the strategy list, these units will be counted as already created and will not be rebuilt.



The computer player is really controlled by two files: the .ai file and another file called a .per file. The .per file contains strategic numbers that the computer player uses to control the actual execution of the strategy contained in a given .ai file. The default strategic number system should work well for most of the strategies that you write. 



Note: After the release of the first version of AI Editor, I promised a PER editor. Since then, many people have asked me what happened to this editor. The answer is that it is not written yet, but it may well be some day, who knows... 



Format of AI Files



The format of the AI files is described shortly here. With AI Editor, you should not worry too much about it, since the editor does most of the job for you. Still, an AI editing guide would be incomplete without it. The description that follows is a very basic one, and you do not need a more thorough one with AI Editor. If you are curious about some details not included in this description, please refer to one of the sources listed in the References section.



Each item in the AI file is placed on a separate line. For example:



//ID 	  Description	       Qty    Parent  Retrains

//---    -------------------  ------ ------  --------- 

T73       Soldier-Inf1         2      12      1



Each item contains 4 or 5 fields. The fifth filed, which is the number of limited retrains, is optional. These fields correspond to the 5 columns you see in the AI Editor main window. Their meaning is given in the table below.



Table 2. Columns in the AI files format

Field�Description��ID�Object code. It consists of a letter prefix and a number. The number is an unique numeric identifier for the objects. The game uses these identifiers internally to refer to game objects. The prefix is one of the letters B, R, A, C, U and T. The meaning of these letters is given in the table below ��Description�Textual description of the object. Generally this is the name of the item. This name must not contain any blanks (spaces or tabs), since they are regarded as delimiters. Note that although this description is required, it is not actually used by the game. You may write there "Blah-blah" if you want. The game retrieves all the information it needs about the object exclusively from the object code.��Qty�Quantity. This is the quantity in which this object will be built at this point. Buildings and units can be built in quantities higher than 1. Technologies can be researched only once, and this is why AI Editor does not let you specify for research objects quantities higher than 1.��Parent�Parent code. Code of the building in which the item is built/researched. For buildings, this code is always -1 (none). By the way, it is a complete mystery to me why this number is included here. By my opinion, the object parent could be derived also from the object code. Anyway, with AI Editor you never need to worry about it.��Retrains�Number of limited retrains for this item. This column can be omitted, in which case it is assumed that the corresponding item must be retrained unlimitedly.��

As mentioned above, each object in the game has a unique ID number. In the strategy file, that ID number is preceded by a qualifying prefix. The prefixes are listed below.



Table 3. Meaning of prefixes

Prefix�Meaning��B�Building. Will be rebuilt if destroyed.��A�Building. Will be rebuilt up to the number of times specified in the "Limited Retrains" column.��R�Research. Item will be researched if possible. If not possible, it will be skipped according to the strategic numbers.��C�Research. Item will be researched if possible. If not possible, the computer player will progress no further until this critical research is done. For example, if the computer player does not have enough food to advance to the Tool Age, it will wait to collect enough food and will not skip the Tool Age).��U�Unit. Will always be replaced if killed.��T�Unit. Will be trained up to the number of times specified in the "Limited Retrains" column. Example: 1 indicates that this unit will be created once. Once killed, this unit will not be created again.��

I think this is enough for the casual AI Editor user. This description can help you understand the output of the AI Editor, that is the format of AI files saved with this utility, if you ever need to mess with it.

General Tips



Here are some tips and guidelines for creating your own .ai files.



First of all, you must be aware that although you give the computer player a list, he generally does not wait for each item to be built in order to progress to the next one. It takes some time to build/research each item. In fact, the computer player tries to build as many items as possible concurrently. Your job is of course to help him as much as you can with this. While building your list, you must constantly ask yourself the question whether the item you are placing can be built concurrently with the items that precede it. Therefore, by ordering your items, you actually specify a priority, not an order. Of course, the order is indeed an order for consecutive items that have the same parent. This is exactly one of the situations you want to avoid.



The following tips, that can be found in every AI guide, are mostly related to this issue. They are rewritten here from the sample AI file, plus some additional comments.



Keep the quantity field down to 1 or 2. Higher quantities will cause the computer player to pause on that item until the quantity is fulfilled.



Do not research or build an item from a building directly after constructing that building. Example: Don’t place Bowman after Archery Range. Doing so may cause the computer to pause on the Bowman until the Archery Range construction is complete. Instead, put another item between the Archery Range and the Bowman.



Do not place two or more items in a row that come from the same building. Example: Priest, followed by Polytheism, Mysticism and Astrology. Instead, stagger items from multiple buildings to ensure that production at one building does not slow progress through the rest of the list. For example: Priest, Man, Polytheism, Man, Mysticism, Market, Astrology.



Limit retrains of early-age infantry and archers. This ensures that when they are killed they will not be retrained. This frees slots (under the population cap) for them to be replaced by higher-level soldiers. The same concept applies to villagers and fishing boats. These units become obsolete in the latter stages of the game, so you don't want them to be retrained every time they are killed.



Limit the number of units trained to approximately 50. When the computer reaches its population cap of 50, its advance through the remainder of the list will slow down. If your list calls for 30 villagers and 30 military units, do the following:

- Put 10 villagers, or early-age soldiers on limited retrain. This will open slots for 10 superior replacements later.

- Put the last 2-10 units you want to have trained in the very last line of the file.

This way, if you exceed the population cap, you will do so on the last item and not interrupt the progress of the list.



Start by modifying an .ai file that is already close in content to the file you want to create. If that list is missing certain items, copy them from the sample .ai file and paste them into your .ai file. This guideline is not so critical when you use AI Editor. With this tool, it is much easier to build AI files from scratch, i.e. starting from nothing. Still, copying and pasting can save you lots of work, of course. So if you have a file to start from, open it in the AI Editor and save it under a new name. In another session of AI Editor, open the sample file stratsmp.ai. When you need an item, you can copy it from the sample file to the clipboard, switch to the other session and paste it there at the appropriate place.



After you have completed your .ai file, you must test it. Put it into a scenario, give the computer unlimited resources, and observe the build process on x2 speed. Ensure that all items are correctly built. Delete items that have limited retrains and ensure that they are replaced with other units. This technique will greatly accelerate your .ai design and development process.



AI Editor Related Tips



Here are some guidelines of my own. They apply to AI Editor exclusively.



Keep your AI status "ok". After each editing operation, take a look at the AI status displayed in the status bar. If it is "BAD", look at the invalid items, hunt down and eliminate your errors. Although the computer player will in some cases cope with your mistakes, do not count on this. Keeping your list correct is a piece of cake with AI Editor. Although this is indeed not the case without it. You will be surprised to know how many of the default AI files distributed with both versions of the game have status "BAD" when loaded in AI Editor. They contain usually minor bugs (1 or 2 misplaced items) which were obviously extremely hard to discover with the usual editing means. We must of course give full credits to the AI designers at ES. They have done a great job, they simply could not do it better.



Decide from the very beginning for which of the versions of the game you are creating your AI file. If it is for the original AoE, choose this game in the Settings dialog. This will prevent you from inadvertently adding RoR-specific items like Camel Riders to the list. If it is for RoR, on the contrary you would like to use the RoR specific stuff as much as you can, since it is an important part of the RoR gameplay. So you should choose RoR in this case, or leave the default setting "Both" , which is in fact equivalent to RoR.



Decide from the very beginning for which of the civilizations of the game you are creating your AI file and specify it in the Settings dialog box. You will rarely use the default setting "All - full tech tree". Civilization related limitations make the game much more interesting and you will generally try to exploit them. For most scenarios, you will not want them to be played in "Full Tech Tree" mode, so you will have to tune your AI files to the civilizations you are using in the scenario.



Place descriptive comments in your files. You can edit these comments in the Comments dialog. Do not forget that by creating an AI file, you are not only programming the AI, but also communicating with humans. You work may and should inspire others. In your comments, you should at least say these things: name, creation date, author, copyright, game (AoE or RoR), civilization, approximate number of units of each kind (refer to the Statistics dialog for this). It is also a good idea to give a long descriptive name to your file. For example, "Choson Swordsmen Iron (RoR).ai" is generally better than "Start25.ai".



Some of your AI files will probably undergo several revisions. Use a revision control system to keep them right. If you are using RCS or compatibles, add a revision identifier and a revision log to your comments. Writing custom AI files is in fact programming, although in a very specific scripting language. Respect and maintain you "source-code" in the way most computer programmers do.



Known Bugs



For now, there are not many bugs I know about in the new version of AI Editor. But there must be bugs, of course. I have not tested it too much in the scenario editing practice. In order to find and eliminate bugs, I need your feedback. Please feel free to notify me about any bugs, limitations, inconsistencies, inconveniences and problems of any kind you discover or dislike. The only way for me to repair them is to know about them.



Here is a short list of things I am aware of. They can hardly be named bugs, but still I somehow don't like them. However, if I repair every detail I dislike, I will probably never release anything at all, so let them go for now.



When you close the application from the close box on the title bar, no confirmation prompt is displayed even if you have modified your file. Thus, you can lose your last changes if you are not careful.



When you save your file under the name of an already existing file, this file is overwritten without any prompting. Be careful not to overwrite important files in this way.



In the Description combo box of the AI Item dialog, items are sorted by their numeric ID. It would may be better if they were sorted alphabetically instead.



In the Description combo box, you generally see only the first units of the upgrade sequences. So you must refer to some documentation or simply remember all upgrade sequences. This is of course not quite difficult since these units are not so many.



Comments are copied verbatim to the output. This means that if you accidentally forget to place the double slash "//" on some of the lines in the Comments dialog, the saved AI file will be invalid. It may well crash the game on load.



No line numbers are associated with items, and it is quite difficult at times to hunt down invalid items only using the descriptions that appear in the Invalid Items dialog.



Only the total number of research, but not the researched technologies themselves, is seen in the Statistics dialog. This is because the list could appear to be too long to be placed there. But of course it could be placed in a list box.



Future Releases



I will try to keep up with the game and provide bug-fixes and updates as bugs are found or updates become necessary. I plan to write also a similar utility for Age of Kings (AoK) when it is available.



Any updates will first of all be posted on the page S. Ratchev in the downloads section of the AoE Heaven site at http://age.gamestats.com/age/downsnew/dwnstoyan.shtml. This site contains also tons of useful stuff for this game. Their number is still growing, so check this great site regularly.



References



In the AI Editor distribution, there are 2 more files that you may refer during your work. 



The Excel sheet objects.xls contains reference information about all 121 game objects. This is in fact the information currently built into the AI Editor. If you find anything incorrect, please notify me. I will then have to update the AI Editor executable, as well as objects.xls.



The file stratsmp.ai is a sample AoE AI file released by Microsoft & ES. It is not a working strategy. Instead, it contains lines for all objects in the original AoE. It can be useful if you want to use the traditional copy/paste editing with AI Editor. This file doesn't contain lines for the 9 RoR-specific objects.



There are also some excellent reference sources on the Net that should be mentioned here.



The most comprehensive AI Editing guide is the set of articles entitled "Breakdown of .ai" on AoE Heaven, http://age.gamestats.com/age/siege/articles/aifiles.shtml. This site contains also a lot of additional reference information of interest to AI designers.



Another excellent reference source about all game objects are the "unit sheets" on the Mr. Fixit site,  http://virtualnj.com/mrfixit/ror/. 



There are of course many sites in the Net devoted to AoE and RoR that may contain undiscovered treasures. AoE Heaven contains a list of most of them in its Town Center section, http://age.gamestats.com/age/town/index.shtml. 



Credits



I would like to thank the following people for supporting and encouraging my work:



Archangel Michael (webmaster@heavenweb.com) for web-mastering the AoE Heaven site at the time when the first version of AI Editor was released and providing me with excellent support and feedback. 



Matt Pritchard (MPritchard@EnsembleStudios.com), the graphics engine and optimization specialist at ES, for maintaining the AoE utility developers mailing list and supporting the work of all of us.



Dave Potinger, the AI guru at ES. All this AI stuff is his creation. 



All people who have emailed me with questions, bug-reports, words of encouragement and complaints. These are too many to be included here - for these 2 years, I have received some hundreds of emails. If they were not so many, I would have probably never written the version 2.0 of AI Editor.



Last but not least Microsoft & Ensemble Studios for creating the greatest RTS game of all times, Age of Empires!



(C) 1997,1999 Stoyan Ratchev - All Rights Reserved.

Email: sratchev@mail.techno-link.com

Last updated on 28 Jun 1999.
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